Welcome to Banzore!

Be part of something great, join today!

BF3 Crashing and Nvidia Cards!!!

Billybong

Well-Known Member
Staff member
Senior Admin
Donator
We have found a fix, well so far it works to stop the CTD for all so far that have tryed it

*right click desktop and select "nvidia control panel"

*under 3d settings on the left select "manage 3d settings"

*on the right select "program settings tab"

*under "1. select a program to customise:" pick "Battlefield 3 (bf3.exe)" from the dropdown box

*under "2. Specify the settings for this program:" scroll to the bottom of the settings

*change "vertical sync" to "force on" then apply (or Auto on)

*launch battlefield 3 and no more CTD
 

CR8Z

Bald fat guy.
-bZ- Member
I wasn't crashing, but I did it anyway.
 
Top